error

ellenaj's picture

Offline

Joined: Feb 20, 2019

Replies: 0
error
February 20, 2019 - 5:21am
Arduino: 1.8.8 (Windows 10), Board: "Adafruit Trinket (ATtiny85 @ 8MHz)"
C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\user\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\user\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\user\Documents\Arduino\libraries -fqbn=adafruit:avr:trinket3 -ide-version=10808 -build-path C:\Users\user\AppData\Local\Temp\arduino_build_716080 -warnings=none -build-cache C:\Users\user\AppData\Local\Temp\arduino_cache_439844 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\user\Desktop\wa\wa.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\user\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\user\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\user\Documents\Arduino\libraries -fqbn=adafruit:avr:trinket3 -ide-version=10808 -build-path C:\Users\user\AppData\Local\Temp\arduino_build_716080 -warnings=none -build-cache C:\Users\user\AppData\Local\Temp\arduino_cache_439844 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.2.1.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\user\Desktop\wa\wa.ino
Using board 'trinket3' from platform in folder: C:\Users\user\AppData\Local\Arduino15\packages\adafruit\hardware\avr\1.4.13
Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=attiny85 -DF_CPU=8000000L -DARDUINO=10808 -DARDUINO_AVR_TRINKET3 -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Users\\user\\AppData\\Local\\Arduino15\\packages\\adafruit\\hardware\\avr\\1.4.13\\variants\\tiny8" "C:\\Users\\user\\AppData\\Local\\Temp\\arduino_build_716080\\sketch\\wa.ino.cpp" -o nul
Error while detecting libraries included by C:\Users\user\AppData\Local\Temp\arduino_build_716080\sketch\wa.ino.cpp
Generating function prototypes...
"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=attiny85 -DF_CPU=8000000L -DARDUINO=10808 -DARDUINO_AVR_TRINKET3 -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Users\\user\\AppData\\Local\\Arduino15\\packages\\adafruit\\hardware\\avr\\1.4.13\\variants\\tiny8" "C:\\Users\\user\\AppData\\Local\\Temp\\arduino_build_716080\\sketch\\wa.ino.cpp" -o "C:\\Users\\user\\AppData\\Local\\Temp\\arduino_build_716080\\preproc\\ctags_target_for_gcc_minus_e.cpp"
wa:15:10: error: #include expects "FILENAME" or <FILENAME>
exit status 1
#include expects "FILENAME" or <FILENAME>
 
i copied the error msg how to solve it?
Abhiemanyu Pandit's picture

Offline

Joined: Jan 21, 2019

Replies: 42
error
February 25, 2019 - 2:31pm

it would be great for us if you send this error along with the code, what is your project and more details. You cannot just post an error without any head or tail of what u are doing