ESP8266 board gets deleted automatically from Arduino IDE

Shivam's picture

Offline

Joined: Sep 11, 2018

Replies: 0
ESP8266 board gets deleted automatically from Arduino IDE
August 5, 2019 - 5:24pm

hello, i am having problem working with esp8266 nodeMCU board in the Arduino IDE. 

i have worked with NodeMCU esp8266 before also and have made several projects on Arduino and Arduino IDE. i installed the ESP8266 board in the Arduino IDE. everything was going well but it is really confusing that why the installed board is getting deleted automatically after sometime. 

this has happened for several time. can anyoe help me why this is happening. i have tried googling it also but no relevent question or answer found. 

thanks in advance.

Abhiemanyu Pandit's picture

Offline

Joined: Jan 21, 2019

Replies: 42
ESP8266 board gets deleted automatically from Arduino IDE
August 5, 2019 - 6:37pm

hello, i have faced this happening with me also. even i was having problem with the esp8266 board deleted automatically. i dont know about other that what could be the reason but in my case this was the problem of antivirus which i was using.

i was using a free antivirus which was causing the automatic deletion of board and other resources. if you have anti virus isntalled then either uninstall it or give grant permission to arduino ide as th trusted software. 

when i deleted my free antivirus software i never faced this problem again. this solved my problem. check if this same can be applied for you also.