LED lights in an electric fireplace

victoria Mcilhone's picture

Offline

Joined: Feb 23, 2021

Replies: 2
LED lights in an electric fireplace
February 23, 2021 - 12:33pm

Hi guys. Have never posted but watch curiously from time to time. 

Whats got me stuck is 2 LED light strips in this Chinese made "fake" fireplace are both powered from the same source. However, one has stopped working. BUT its not the LED's itself but the power. I can switch power between the strips and will work, but I cant get both to work simultaneously. 

Logically its got me beat. Connections have been checked and no other problems....

Any ideas?

Stuart & Victoria

Sourav Gupta's picture

Offline

Joined: Feb 12, 2018

Replies: 665

Can you post the image of the construction?

victoria Mcilhone's picture

Offline

Joined: Feb 23, 2021

Replies: 2

Thanks Sourav,

2 photos show 1 LED strip removed but in testing position. Red and yellow cable powers both sides but only 1 works at a time. Have switched around LED's and both work but never at once. Was working fine until a month ago

 

 

victoria Mcilhone's picture

Offline

Joined: Feb 23, 2021

Replies: 2

Actually site wont let me attach image. Any tips on how to do that amyone? Thanks

Sourav Gupta's picture

Offline

Joined: Feb 12, 2018

Replies: 665

did you connected 2 LED strips in series? make sure the polarity is correct. You can try connecting the same in parallel.

Leonard Jeffrey's picture

Offline

Joined: Oct 22, 2021

Replies: 7

All I can think of is that the power supply is slowly dying and not able to supply the current as it once did when new.

Sourav Gupta's picture

Offline

Joined: Feb 12, 2018

Replies: 665

There are no compoennts that could cause such issues irrespective of capacitors.