Cause for Trembling of LED Tube Light and Flickering of others output with the flickering Fluorescent Tube Light(FTL).

RAHAMANSA's picture

Offline

Joined: Sep 15, 2017

Replies: 9
Cause for Trembling of LED Tube Light and Flickering of others output with the flickering Fluorescent Tube Light(FTL).
September 27, 2018 - 11:09pm

Hi,

I made a PCB for ON/OFF/DIM control with MCU, Opto for ZC and one more opto to fire TRIAC and others requisite passive components to control on/off /dim the 230v appliances.

All are working correctly when the load is Lamp(CFL/Incandescent) and Fan (if component is placed either in PCB/Breadbord)

but for the case of: 

1) FTL(with Magnetic choke/40W):- when the Triac is turned-ON to turn the connected FTL ON, the others output connected to others triac getting flickering(when turned OFF) with the flickering of FTL.  (tested on Breadboard)  

 

2) LED Tube Light(18W): when the Triac is turned-ON to turn the connected LED Tube Light ON,​ the LED getting  ON correctly, but sometimes in the midst after rightly turning on it is noticed that the light of the LED Tube Light getting trembling/vibrating and a hissing noise is also noticed. (tested on PCB)   

 

Can anyone help me out against both the case.

 

Thx

 

 

Jayant's picture

Offline

Joined: May 19, 2015

Replies: 210
1) FTL(with Magnetic choke
September 28, 2018 - 5:47pm

1) FTL(with Magnetic choke/40W):- when the Triac is turned-ON to turn the connected FTL ON, the others output connected to others triac getting flickering(when turned OFF) with the flickering of FTL.  (tested on Breadboard)  

I wonder how you tested an AC circuit on breadboard. Are you referring to florescent Lamps when you mention FTL? If yes these lamps are normally rated to 35W have you considered the current and voltage while selecting the TRIAC? It will be hard to help you without the circuit diagram. How have  you connected the other loads? Have you tried changing the ballast a.k.a choke? 

 

2) LED Tube Light(18W): when the Triac is turned-ON to turn the connected LED Tube Light ON,​ the LED getting  ON correctly, but sometimes in the midst after rightly turning on it is noticed that the light of the LED Tube Light getting trembling/vibrating and a hissing noise is also noticed. (tested on PCB)   

LED lights have very rare chance to Hum, this is because they have no AC component inside. But still if you experience humming it is mostly due to electro magnetic interface. But if you are experiencing this problem when you are trying to DIM the LED then the story is completely different.

I assume that you are aware that unlike florescent of incandescent lamps LED lamps cannot be dimmed by changing the voltage applied to it. This is because the driver IC which converts the AC to DC for making the LED glow is designed to operate only for a specific input voltage range.  

RAHAMANSA's picture

Offline

Joined: Sep 15, 2017

Replies: 9
Hi, 
September 28, 2018 - 10:09pm

Hi, 

Thnx for your reply..

 

###For the case of No 1: (Mounted on breadboard)::

Yes,  florescent Lamp referred as FTL. All the triac are used here BT136 (600V/4Amps) for all o/p. And MT1 is connected at LOAD (here as HOT of the FTL) and MT2 connected with HOT and Gate at output of Opto.

 

###For the case of No 2: (mounted on PCB)::

I know it cant be dimmed and not even tried to dim it (other that FAN). And light is not generating Hum noise, the noise is coming from PCB when the LED-Tube-light is turned ON. what I have been experiencing are as, 

A) Hum noise from PCB: till the LED-Tube-light is turned ON.

B) During turned On condition, light of the LED-Tube-Light getting SOMETIMES trembling/vibrating. 

 

CKT.jpg

 

 

 

 

 

 

 

 

 

 

 

Others load is connected through the same ckt with pin D1 and D2.

 

Thnx.

Jayant's picture

Offline

Joined: May 19, 2015

Replies: 210
Resistor missing in circuit diagram
September 30, 2018 - 11:15am

I assume the U3 in the circuit is something similar to MOC3021 Triac driver. I am posting a sample dimmer circuit

AC-board-schematic.jpg

If you compare this circuit with yours you can notice that the resistor R5 is missing gin your circuit. Also the snubber components R4 and C1 is also missing. It is also highly recommended to use a fuse when dealing with AC loads.

As you know, these components are not mandatory, but the snubber circuit there would sure help you in sorting few un expected problems that you are facing now. 

RAHAMANSA's picture

Offline

Joined: Sep 15, 2017

Replies: 9
Yes, U3-> MOC3021, my actual
October 3, 2018 - 9:46pm

Yes, U3-> MOC3021, my actual ckt is here. I have also tested with snubber as below but issues are still there.

In addition to all above issues, If I use TRIAC BT136(600E and 600D) instead of BT136(600) with the circuit with/without snubber the others output (with load CFL and FTL) getting turned ON on Turning ON of FAN and , also the light start flickering on changing of speed of FAN.

What is actually problems and how can it be remove please suggest.

CKT1.jpg

tnx

Shivani Umredkar's picture

Offline

Joined: Aug 09, 2019

Replies: 1
Yes almost same circuit use in my kit and getting same issue
August 9, 2019 - 2:08pm

Hi,

I am also using BT136 with MOC3021 to drive the AC bulb. Similar issue which discuss above threads I am getting, my corresponding load get blink if I turn on any of other load. The appliences connected  with my kit some LED, fan, and Bulb. I have noted voltages also getting spikes. I have search for this issue, many of getting similar issue with BT136 but I didnt found any solution. Please help me what are possibilities of this issue and what are the test cases I should perform to remove this spikes from my circuit.