Electrets don't work

I am having a problem making electrets work in various circuits I’ve taken from Charles Platt”s “Make: More Electronics,” 2016. The simplest is on page

59. It connects an electret to ground on a breadboard, and also to a 4.7K resistor. The latter is attached to the positive bus. I then measure AC volts

between ground and a point between the electret and the resistor. 

I first tried using this brand: HiLetgo 10pcs Electret Condenser Microphone 52dB MP3 Microphone Accessories 6x2.2mm, which I got from Amazon. The first of these electrets worked the first couple of times I spoke aloud to test it, then didn’t work. The next couple of electrets were the same, so I sent them all back. I then got, also from Amazon, this brand: BOJACK 9767 Cylindrical Electret Microphone 2 Pins 9.7 x 6.7 mm Microphone for Intelligent Robot (Pack of 10 Pcs), which hasn’t worked at all.

The book says to measure AC voltage both before, and while, speaking aloud. I should register, the book says, .1 (point one) millivolts before speaking and 10-20 mV while speaking. I have gotten a stable reading (about 5 mV with the first brand and 9 mV with the second) before speaking. With the first brand I got a higher reading when I spoke, but the readout varied quickly. I think it was maybe 2-3 volts. With the second brand I get no increase at all.

It seems doubtful that both brands would be defective and, rather, that I’m somehow getting the procedure wrong. I’d be grateful for any opinions.